summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-01-30 16:14:28 -0600
committerDudemanguy <random342@airmail.cc>2023-01-31 14:50:02 +0000
commit78d9b40ddcaf68dce50241c4e4ece7c0559d70d5 (patch)
tree4faa3aadd54f543c9901725c65f6da8716f6a1fd /meson.build
parent25f5333b4a3424a95de6d3afd541e1f9b9bdb04f (diff)
downloadmpv-78d9b40ddcaf68dce50241c4e4ece7c0559d70d5.tar.bz2
mpv-78d9b40ddcaf68dce50241c4e4ece7c0559d70d5.tar.xz
meson: replace check_header with has_header
It turns out that there's a has_header check, and we should actually be using that instead. We only care here if the header actually exists so the pre-processor check is all that is needed. check_header depends on what arguments the user passes among other things. That makes it more complicated than necessary for our purposes.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9a3bdd2eeb..71e78e84e4 100644
--- a/meson.build
+++ b/meson.build
@@ -888,7 +888,7 @@ direct3d_opt = get_option('direct3d').require(
get_option('gpl') and features['win32-desktop'],
error_message: 'the build is not GPL or this is not a win32 desktop!',
)
-direct3d = cc.check_header('d3d9.h', required: direct3d_opt)
+direct3d = cc.has_header('d3d9.h', required: direct3d_opt)
features += {'direct3d': direct3d}
if features['direct3d']
sources += files('video/out/vo_direct3d.c')
@@ -989,7 +989,7 @@ wayland = {
dependency('wayland-cursor', version: '>= 1.15.0', required: get_option('wayland')),
dependency('wayland-protocols', version: '>= 1.15', required: get_option('wayland')),
dependency('xkbcommon', version: '>= 0.3.0', required: get_option('wayland'))],
- 'header': cc.check_header('linux/input-event-codes.h', required: get_option('wayland')),
+ 'header': cc.has_header('linux/input-event-codes.h', required: get_option('wayland')),
'scanner': find_program('wayland-scanner', required: get_option('wayland')),
}
wayland_deps = true