summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-01-30 14:40:49 -0600
committerDudemanguy <random342@airmail.cc>2023-01-31 14:50:02 +0000
commit25f5333b4a3424a95de6d3afd541e1f9b9bdb04f (patch)
tree68834e54ac7c6dd6731f4784acbd502da54fdb53 /meson.build
parent9659555d45397357195558ff6f936bdbdc8137d4 (diff)
downloadmpv-25f5333b4a3424a95de6d3afd541e1f9b9bdb04f.tar.bz2
mpv-25f5333b4a3424a95de6d3afd541e1f9b9bdb04f.tar.xz
meson: actually use -Werror=format-security
We tested for this flag, but never added -Wformat in addition to -Werror=format-security. The latter was silently ignored and actually did nothing.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 45b9dbbf54..9a3bdd2eeb 100644
--- a/meson.build
+++ b/meson.build
@@ -271,7 +271,7 @@ test_flags = ['-Werror=implicit-function-declaration',
flags += cc.get_supported_arguments(test_flags)
if cc.has_multi_arguments('-Wformat', '-Werror=format-security')
- flags += '-Werror=format-security'
+ flags += ['-Wformat', '-Werror=format-security']
endif
if cc.get_id() == 'gcc'