summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGusar321 <mobile.leecher@gmail.com>2023-07-24 11:50:19 +0200
committersfan5 <sfan5@live.de>2023-07-24 22:27:54 +0200
commit290253291788032c465ee27cccd60a2d1ec8c182 (patch)
treece42ec388080b69b1e632f0f0f64caf59fc88f9b /meson.build
parent2e3cb30e46eda324af760dd7a731ef6f0a0ce2b4 (diff)
downloadmpv-290253291788032c465ee27cccd60a2d1ec8c182.tar.bz2
mpv-290253291788032c465ee27cccd60a2d1ec8c182.tar.xz
build: vaapi-egl should explicitly depend on egl
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8aeb77848d..ccad5c1ca0 100644
--- a/meson.build
+++ b/meson.build
@@ -1424,7 +1424,7 @@ if features['vaapi-x11']
endif
features += {'vaapi-x-egl': features['vaapi-x11'] and egl_x11.allowed()}
-features += {'vaapi-egl': features['vaapi-x11'] or features['vaapi-wayland'] or features['vaapi-drm']}
+features += {'vaapi-egl': (features['vaapi-x11'] or features['vaapi-wayland'] or features['vaapi-drm']) and features['egl']}
features += {'vaapi-libplacebo': features['vaapi'] and libplacebo.found()}
if features['vaapi-egl'] or features['vaapi-libplacebo']