summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGusar321 <mobile.leecher@gmail.com>2023-07-24 11:47:44 +0200
committersfan5 <sfan5@live.de>2023-07-24 22:27:54 +0200
commit2e3cb30e46eda324af760dd7a731ef6f0a0ce2b4 (patch)
tree4cae7c8a3ba58375ea3c25faeb433209ea67da7b /meson.build
parentff3739b36e5b169ea948afbb30f73f34383248b3 (diff)
downloadmpv-2e3cb30e46eda324af760dd7a731ef6f0a0ce2b4.tar.bz2
mpv-2e3cb30e46eda324af760dd7a731ef6f0a0ce2b4.tar.xz
build: vaapi-drm and vaapi-wayland do not depend on egl
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index de396b9f1f..8aeb77848d 100644
--- a/meson.build
+++ b/meson.build
@@ -1405,13 +1405,13 @@ if features['vaapi']
endif
vaapi_drm = dependency('libva-drm', version: '>= 1.1.0', required: get_option('vaapi-drm').require(features['vaapi']))
-features += {'vaapi-drm': features['vaapi'] and egl_drm.allowed() and vaapi_drm.found()}
+features += {'vaapi-drm': features['vaapi'] and vaapi_drm.found()}
if features['vaapi-drm']
dependencies += vaapi_drm
endif
vaapi_wayland = dependency('libva-wayland', version: '>= 1.1.0', required: get_option('vaapi-wayland').require(features['vaapi']))
-features += {'vaapi-wayland': features['vaapi'] and features['egl-wayland'] and vaapi_wayland.found()}
+features += {'vaapi-wayland': features['vaapi'] and vaapi_wayland.found()}
if features['vaapi-wayland']
dependencies += vaapi_wayland
endif