summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2022-10-28 22:01:25 -0500
committerDudemanguy <random342@airmail.cc>2022-10-29 17:55:33 +0000
commit0fa5bfae247b6b997a81902dd29d4a29cbe16e0c (patch)
tree4b5f4144db4ef2893ec9838a583aab9f759eb4d1 /meson.build
parent6ebc4928c52f14a762a2872e4960289cade364e5 (diff)
downloadmpv-0fa5bfae247b6b997a81902dd29d4a29cbe16e0c.tar.bz2
mpv-0fa5bfae247b6b997a81902dd29d4a29cbe16e0c.tar.xz
meson: use 'dl' instead of 'libdl' in find_library
Meson's master branch helpfully prints out a warning here now saying that "find_library('libdl') starting in "lib" only works by accident and is not portable". We'll go ahead and trust them and instead change this to dl which works with no issues.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f38f2d9237..574baf2bb3 100644
--- a/meson.build
+++ b/meson.build
@@ -327,7 +327,7 @@ endif
features += {'ta-leak-report': get_option('ta-leak-report')}
-libdl_dep = cc.find_library('libdl', required: false)
+libdl_dep = cc.find_library('dl', required: false)
features += {'libdl': libdl_dep.found() and cc.has_function('dlopen', dependencies: libdl_dep, prefix: '#include <dlfcn.h>')}
if features['libdl']
dependencies += libdl_dep