summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2022-10-28 21:40:53 -0500
committerDudemanguy <random342@airmail.cc>2022-10-29 17:55:33 +0000
commit6ebc4928c52f14a762a2872e4960289cade364e5 (patch)
treed80acc385c6dc82dfe9e3856af7ef78a1b11d55f /meson.build
parent89bd6ead6c6f710c42ce2f6f4c5abdb157090761 (diff)
downloadmpv-6ebc4928c52f14a762a2872e4960289cade364e5.tar.bz2
mpv-6ebc4928c52f14a762a2872e4960289cade364e5.tar.xz
ci: use meson setup build instead of meson build
The old "meson build" build command was actually deprecated a few months ago*. It turns out that you're supposed to use "meson setup build" instead which has been around for years. Go ahead and be a good citizen and update this in the CI. Also replace any mention of "meson build" with "meson setup build" in the documentation as well and change the one random hardcoded string we have in meson.build to "meson configure build" (might as well). *: https://github.com/mesonbuild/meson/commit/3c7ab542c0c4770241eae149b0d4cd8de329aee0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6d85b4e3cb..f38f2d9237 100644
--- a/meson.build
+++ b/meson.build
@@ -1590,7 +1590,7 @@ endif
# We can't easily get every single thing a user might have passed on the cli,
# but we might as well add prefix (even if it's not specifically set) since
# it's highly relevant and useful.
-configuration = 'meson build '
+configuration = 'meson configure build '
configuration += '-Dprefix=' + get_option('prefix')
features += {'cplayer': get_option('cplayer')}