summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authoreyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2001-07-28 07:53:11 +0000
committereyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2001-07-28 07:53:11 +0000
commitba516b3a40acfc92f59ad786119b0594d5e5a98e (patch)
tree63b012cc4f6bb2cc11b2a34df1af14fd4c2a688c /debian/rules
parentfbeeb770507c1df789c90157212ef9bc36f0a6b0 (diff)
downloadmpv-ba516b3a40acfc92f59ad786119b0594d5e5a98e.tar.bz2
mpv-ba516b3a40acfc92f59ad786119b0594d5e5a98e.tar.xz
using debhelper instead of hardcoded stuff
git-svn-id: svn://svn.mplayerhq.hu/mplayer/trunk@1398 b3059339-0415-0410-9bf9-f77b7e298cf2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules117
1 files changed, 87 insertions, 30 deletions
diff --git a/debian/rules b/debian/rules
index 5da54c6aec..b6a3709564 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,55 +1,112 @@
#!/usr/bin/make -f
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
+#export DH_VERBOSE=1
+# This is the debhelper compatability version to use.
+export DH_COMPAT=1
package=mplayer
-build:
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
$(checkdir)
./configure --prefix=/usr
+
+ touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+ dh_testdir
+
+ # Add here commands to compile the package.
+ #$(MAKE)
+ #/usr/bin/docbook-to-man debian/etherconf.sgml > etherconf.1
make dep
make mplayer
- touch build
+
+
+ touch build-stamp
clean:
- $(checkdir)
- -rm -f build
- -$(MAKE) distclean
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
+ # Add here commands to clean up after the build process.
+ #-$(MAKE) clean
+# $(checkdir)
+# -rm -f build
+# -$(MAKE) distclean
+# -rm -f `find . -name "*~"`
+# -rm -rf debian/tmp debian/files* core debian/substvars
+ dh_clean
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/<packagename>
+# $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
$(MAKE) install prefix=`pwd`/debian/tmp/usr
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdebconf
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+ dh_installman
+ dh_installinfo
+# dh_undocumented
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+ dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+
+
+#binary-arch: checkroot build
+# $(checkdir)
+# -rm -rf debian/tmp
+# install -d debian/tmp
+# cd debian/tmp && install -d `cat ../dirs`
+
# Must have debmake installed for this to work. Otherwise please copy
# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- debstd
- dpkg-gencontrol -isp
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
+# debstd
+# dpkg-gencontrol -isp
+# chown -R root.root debian/tmp
+# chmod -R go=rX debian/tmp
+# dpkg --build debian/tmp ..
binary: binary-indep binary-arch
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
.PHONY: binary binary-arch binary-indep clean checkroot