summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authoreyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2001-07-28 07:53:11 +0000
committereyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2001-07-28 07:53:11 +0000
commitba516b3a40acfc92f59ad786119b0594d5e5a98e (patch)
tree63b012cc4f6bb2cc11b2a34df1af14fd4c2a688c /debian
parentfbeeb770507c1df789c90157212ef9bc36f0a6b0 (diff)
downloadmpv-ba516b3a40acfc92f59ad786119b0594d5e5a98e.tar.bz2
mpv-ba516b3a40acfc92f59ad786119b0594d5e5a98e.tar.xz
using debhelper instead of hardcoded stuff
git-svn-id: svn://svn.mplayerhq.hu/mplayer/trunk@1398 b3059339-0415-0410-9bf9-f77b7e298cf2
Diffstat (limited to 'debian')
-rw-r--r--debian/TODO.Debian3
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules117
4 files changed, 95 insertions, 33 deletions
diff --git a/debian/TODO.Debian b/debian/TODO.Debian
index ae6d4dcb48..5329f2c0a8 100644
--- a/debian/TODO.Debian
+++ b/debian/TODO.Debian
@@ -1,3 +1,4 @@
+- create packages of mp_font3 and win32codecs, depend/recommend them.
- fibmap_mplayer - figure out what to do with suid.
- global configuration
( /etc/mplayer/mplayer.conf
@@ -7,5 +8,3 @@
or figure out some other way of satisfying other dependencies
like *.dlls and fonts.
In other words - automate win32dll.zip installation.
-- check debhelper quirks and abilities for config files.
-
diff --git a/debian/changelog b/debian/changelog
index 40446a2e01..0dd1887b36 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+mplayer (0.18-2) unstable; urgency=low
+
+ * modified debian scripts
+
+ -- Dariush Pietrzak <eyck@ghost.tinet.pl> Fri, 27 Jul 2001 09:25:52 +0200
+
mplayer (0.18-1) unstable; urgency=low
* lots of changes in mplayer
diff --git a/debian/control b/debian/control
index 1ae9d80afa..78fc605355 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Standards-Version: 3.2.1
Package: mplayer
Architecture: any
-Depends: ${shlibs:Depends},debconf
+Depends: ${shlibs:Depends},debconf,libconfhelper-perl
Description: The Ultimate Movie Player For Linux
MPlayer is a movie player for LINUX. It plays most MPEG, AVI and ASF files,
supported by many native and Win32 DLL codecs. You can watch VCD, DVD and even
diff --git a/debian/rules b/debian/rules
index 5da54c6aec..b6a3709564 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,55 +1,112 @@
#!/usr/bin/make -f
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
+#export DH_VERBOSE=1
+# This is the debhelper compatability version to use.
+export DH_COMPAT=1
package=mplayer
-build:
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
$(checkdir)
./configure --prefix=/usr
+
+ touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+ dh_testdir
+
+ # Add here commands to compile the package.
+ #$(MAKE)
+ #/usr/bin/docbook-to-man debian/etherconf.sgml > etherconf.1
make dep
make mplayer
- touch build
+
+
+ touch build-stamp
clean:
- $(checkdir)
- -rm -f build
- -$(MAKE) distclean
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
+ # Add here commands to clean up after the build process.
+ #-$(MAKE) clean
+# $(checkdir)
+# -rm -f build
+# -$(MAKE) distclean
+# -rm -f `find . -name "*~"`
+# -rm -rf debian/tmp debian/files* core debian/substvars
+ dh_clean
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/<packagename>
+# $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
$(MAKE) install prefix=`pwd`/debian/tmp/usr
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdebconf
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+ dh_installman
+ dh_installinfo
+# dh_undocumented
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+ dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+
+
+#binary-arch: checkroot build
+# $(checkdir)
+# -rm -rf debian/tmp
+# install -d debian/tmp
+# cd debian/tmp && install -d `cat ../dirs`
+
# Must have debmake installed for this to work. Otherwise please copy
# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- debstd
- dpkg-gencontrol -isp
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
+# debstd
+# dpkg-gencontrol -isp
+# chown -R root.root debian/tmp
+# chmod -R go=rX debian/tmp
+# dpkg --build debian/tmp ..
binary: binary-indep binary-arch
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
.PHONY: binary binary-arch binary-indep clean checkroot