summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorKevin Mitchell <kevmitch@math.sfu.ca>2014-01-27 23:16:07 -0800
committerKevin Mitchell <kevmitch@math.sfu.ca>2014-01-27 23:16:07 -0800
commit6c279b73c4a42b772a63780de408733b042a87ed (patch)
treeb2934ca66ac1c4f429f5d36f7f4b0328d5c37d30 /debian
parentdede8140fc6c5bcfaa02e4925f8f80a864fe07c1 (diff)
downloadmpv-build-6c279b73c4a42b772a63780de408733b042a87ed.tar.bz2
mpv-build-6c279b73c4a42b772a63780de408733b042a87ed.tar.xz
Bring back a waf-compatible deiban build system
For override_dh_auto_install, just tell waf to install the files under debian/mpv. The main problem was that the script names clean,build,install in the root directory collided with makefile targets in debian/rules which lead make to do nothing since they appeared already up-to-date. .PHONY wasn't enough since the targets are implicit via the % operator. I had to explicitly declare the problematic targets AND list them as .PHONY
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules32
1 files changed, 29 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 9ad668a..2bff34f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,39 @@
#! /usr/bin/make -f
+# make .PHONY all the targets that have name collisions with the scripts
+# see http://www.debian.org/doc/manuals/maint-guide/dreq.en.html#rules
+.PHONY: clean build install
+# Apparently, the above isn't enough because of the "%" target. Make the problematic targets explicit
+clean:
+ exec dh $@ --parallel
+build:
+ exec dh $@ --parallel
+install:
+ exec dh $@ --parallel
+# handle all other targets in the usual way
%:
exec dh $@ --parallel
-override_dh_auto_build:
+ffmpeg_config:
scripts/ffmpeg-config
- scripts/ffmpeg-build
+ffmpeg_build:ffmpeg_config
+ scripts/ffmpeg-build
+libass_config:
scripts/libass-config
+libass_build:libass_config
scripts/libass-build
- scripts/mpv-config --prefix=/usr
+
+# the dependencies must be built before mpv is configured
+override_dh_auto_configure:ffmpeg_build libass_build
+ scripts/mpv-config --prefix=/usr --confdir=/etc/mpv
+
+override_dh_auto_build:
scripts/mpv-build
+override_dh_auto_install:
+ (cd mpv;python ./waf -v install --destdir=../debian/mpv)
+
+override_dh_auto_clean:
+ scripts/mpv-clean
+ scripts/ffmpeg-clean
+ scripts/libass-clean