summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorKevin Mitchell <kevmitch@math.sfu.ca>2014-01-27 16:18:36 -0800
committerKevin Mitchell <kevmitch@math.sfu.ca>2014-01-27 16:18:36 -0800
commitdede8140fc6c5bcfaa02e4925f8f80a864fe07c1 (patch)
tree6de93f868b594a573f47407b8295d7f2670dd497 /debian
parentb81da58633635ceee40bf5530fa3f97b92dee623 (diff)
downloadmpv-build-dede8140fc6c5bcfaa02e4925f8f80a864fe07c1.tar.bz2
mpv-build-dede8140fc6c5bcfaa02e4925f8f80a864fe07c1.tar.xz
Revert "Remove incomprehensible Debian magic"
This reverts commit ba60c400ae5c69bd8b7f6c1368e6e8c6bfb42f24.
Diffstat (limited to 'debian')
-rw-r--r--debian/README.debian6
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rw-r--r--debian/copyright7
-rw-r--r--debian/dirs2
-rw-r--r--debian/mime20
-rwxr-xr-xdebian/rules13
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options2
10 files changed, 69 insertions, 0 deletions
diff --git a/debian/README.debian b/debian/README.debian
new file mode 100644
index 0000000..b3e2ac3
--- /dev/null
+++ b/debian/README.debian
@@ -0,0 +1,6 @@
+mpv for Debian
+--------------
+
+ You can build the package using 'debuild -uc -us -b -j<number of jobs>'.
+
+-- Wessel Dankers <wsl@fruit.je>, Sun, 06 Jan 2013 13:44:11 +0100
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..927c2cf
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+mpv (1.0git) stable; urgency=low
+
+ * Initial package.
+
+ -- Wessel Dankers <wsl@fruit.je> Sun, 06 Jan 2013 13:44:11 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..d1bf49a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: mpv
+Section: misc
+Priority: optional
+Maintainer: Wessel Dankers <wsl@fruit.je>
+Standards-Version: 3.9.3
+Build-Depends: c-compiler, libjpeg-dev, libvdpau-dev, zlib1g-dev, x11proto-core-dev, libx11-dev, libxext-dev, libxinerama-dev, libxv-dev, libfreetype6-dev, libfribidi-dev, libfontconfig1-dev, libgl1-mesa-dev, debhelper (>= 7), autoconf, automake, libtool, yasm, libpulse-dev, libasound2-dev, libbluray-dev, python3-docutils, libdvdread-dev
+
+Package: mpv
+Architecture: any
+Depends: ${shlibs:Depends},debconf
+Description: mplayer/mplayer2 based video player
+ MPV is a versatile CLI movie player, based on mplayer and mplayer2.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..03a2b2c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,7 @@
+This package was debianized by Wessel Dankers <wsl@fruit.je> on
+Sun, 06 Jan 2013 13:44:11 +0100.
+
+Original source can be found at: https://github.com/mpv-player
+
+Copyrighted by various authors. Licensed under the terms of GNU GPL.
+See /usr/share/common-licenses/GPL for details.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..98d1583
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/share/man/man1
diff --git a/debian/mime b/debian/mime
new file mode 100644
index 0000000..e405227
--- /dev/null
+++ b/debian/mime
@@ -0,0 +1,20 @@
+application/x-ogg; mpv %s; description="Ogg Stream"
+application/ogg; mpv %s; description="Ogg Stream"
+audio/mpeg; mpv %s; description="MPEG Audio"
+audio/x-mpegurl; mpv %s; description="Icecast Playlist"
+audio/x-ms-wax; mpv %s; description="Windows Media Audio"
+audio/x-ms-wma; mpv %s; description="Windows Media Audio"
+audio/x-pls; mpv %s; description="MP3 ShoutCast/IceCast Playlist"
+audio/x-scpls; mpv %s; description="Shoutcast Playlist"
+audio/x-wav; mpv %s; description="WAV Audio"
+video/mpeg; mpv %s; description="MPEG Video";
+video/quicktime; mpv %s; description="Apple QuickTime Video";
+video/x-mpeg; mpv %s; description="MPEG Video";
+video/x-mpeg2; mpv %s; description="MPEG-2 Video";
+video/x-msvideo; mpv %s; description="MS Video (AVI)";
+video/x-ms-afs; mpv %s; description="Microsoft ASF Video";
+video/x-ms-asf; mpv %s; description="Microsoft ASF Video";
+video/x-ms-wma; mpv %s; description="Windows Media Audio";
+video/x-ms-wmv; mpv %s; description="Windows Media Video";
+video/x-ms-wmx; mpv %s; description="Windows Media Video";
+video/x-ms-wvx; mpv %s; description="Windows Media Video";
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9ad668a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#! /usr/bin/make -f
+
+%:
+ exec dh $@ --parallel
+
+override_dh_auto_build:
+ scripts/ffmpeg-config
+ scripts/ffmpeg-build
+ scripts/libass-config
+ scripts/libass-build
+ scripts/mpv-config --prefix=/usr
+ scripts/mpv-build
+
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..659f59c
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1,2 @@
+compression = xz
+compression-level = best