summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2022-04-04 23:41:23 +0200
committerOneric <oneric@oneric.stub>2022-05-12 21:13:00 +0200
commita2b39cde4ecb74d5e6fccab4a5f7d8ad52b2b1a4 (patch)
treef72dab3f4477d684ccb0839ed07aaf141f7f9eb6 /libass/Makefile.am
parent1af6240c5d1e499326146e0b88c987e626b13c23 (diff)
downloadlibass-a2b39cde4ecb74d5e6fccab4a5f7d8ad52b2b1a4.tar.bz2
libass-a2b39cde4ecb74d5e6fccab4a5f7d8ad52b2b1a4.tar.xz
Switch to non-recursive Makefile
Non-recursive Makefiles allow better and more robust automatic dependency resolution and higher parallelism for shorter build-times. This change keeps all locations of the non-installed targets unchanged for minimal firction. Calling make from subdirectories no longer works, but instead the specific build targets can be invoked directly from the toplevel. If we bumped the required Automake version to 1.13+, the library fragment could use %reldir% or %D% to be unaffected by potential future directory moves, but it is unlikely we'll ever change the location or name of the libass directory.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am60
1 files changed, 0 insertions, 60 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
deleted file mode 100644
index 50a779f..0000000
--- a/libass/Makefile.am
+++ /dev/null
@@ -1,60 +0,0 @@
-AM_CFLAGS = -std=gnu99 -Wall -Wextra -Wno-sign-compare -Wno-unused-parameter \
- -Werror-implicit-function-declaration -Wstrict-prototypes \
- -Wpointer-arith -Wredundant-decls -Wno-missing-field-initializers\
- -D_GNU_SOURCE
-
-LIBASS_LT_CURRENT = 10
-LIBASS_LT_REVISION = 4
-LIBASS_LT_AGE = 1
-
-nasm_verbose = $(nasm_verbose_$(V))
-nasm_verbose_ = $(nasm_verbose_$(AM_DEFAULT_VERBOSITY))
-nasm_verbose_0 = @echo " NASM " $@;
-
-.asm.lo:
- $(nasm_verbose)$(LIBTOOL) $(AM_V_lt) --tag=CC --mode=compile $(top_srcdir)/ltnasm.sh $(AS) $(ASFLAGS) -I$(srcdir)/ -Dprivate_prefix=ass -o $@ $<
-
-SRC_X86 = x86/rasterizer.asm x86/blend_bitmaps.asm x86/be_blur.asm x86/blur.asm x86/cpuid.asm \
- x86/cpuid.h
-
-SRC_FONTCONFIG = ass_fontconfig.c ass_fontconfig.h
-SRC_DIRECTWRITE = ass_directwrite.c ass_directwrite.h ass_directwrite_info_template.h dwrite_c.h
-SRC_CORETEXT = ass_coretext.c ass_coretext.h
-
-lib_LTLIBRARIES = libass.la
-libass_la_SOURCES = ass.h ass.c ass_types.h ass_utils.h ass_utils.c \
- ass_compat.h ass_string.h ass_string.c ass_strtod.c \
- ass_filesystem.h ass_filesystem.c ass_library.h ass_library.c \
- ass_cache.h ass_cache.c ass_cache_template.h \
- ass_font.h ass_font.c ass_fontselect.h ass_fontselect.c \
- ass_render.h ass_render.c ass_render_api.c \
- ass_parse.h ass_parse.c ass_priv.h ass_shaper.h ass_shaper.c \
- ass_outline.h ass_outline.c ass_drawing.h ass_drawing.c \
- ass_rasterizer.h ass_rasterizer.c ass_rasterizer_c.c \
- ass_bitmap.h ass_bitmap.c ass_blur.c ass_func_template.h wyhash.h
-
-libass_la_LDFLAGS = -no-undefined -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
-libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym
-
-if FONTCONFIG
-libass_la_SOURCES += $(SRC_FONTCONFIG)
-endif
-
-if DIRECTWRITE
-libass_la_SOURCES += $(SRC_DIRECTWRITE)
-endif
-
-if CORETEXT
-libass_la_SOURCES += $(SRC_CORETEXT)
-endif
-
-if ASM
-if X86
-libass_la_SOURCES += $(SRC_X86)
-endif
-endif
-
-assheadersdir = $(includedir)/ass
-dist_assheaders_HEADERS = ass.h ass_types.h
-
-EXTRA_DIST = libass.sym x86/x86inc.asm x86/utils.asm