summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2022-05-12 14:32:22 +0300
committerOleg Oshmyan <chortos@inbox.lv>2022-05-12 17:02:57 +0300
commit1af6240c5d1e499326146e0b88c987e626b13c23 (patch)
tree85732dc9a399146cfe509d3fc03e980fb5f9b2af /libass/Makefile.am
parent7b0ebafade1bb7149764cf6f5cb713c87ef27869 (diff)
downloadlibass-1af6240c5d1e499326146e0b88c987e626b13c23.tar.bz2
libass-1af6240c5d1e499326146e0b88c987e626b13c23.tar.xz
Release 0.16.00.16.0
This release brings a new `ASS_FEATURE_WHOLE_TEXT_LAYOUT` API toggle, brings an important API change on (only) Microsoft's Win32 platform to enable arbirtrary paths to be used rather than only ANSI ones, fixes an incompatibility with FreeType versions >= 2.11.1 on Win32 and brings many more bug and compatibility fixes as well as other improvements. API users are highly encouraged to pay special attention to the following points: * The documentation has been expanded and multiple errors in it have been fixed. It may be worthwhile to reread the documentation for all functions you are using (or all of it). If you still have questions afterwards or spot an error, please contact us so the docs can be further improved. * For those on Win32 only (other platforms do not require special handling of the path's encoding): The new support for arbitrary paths via the new dual encoding used in the majority of our API is mostly backward compatible, i.e. continuing to use `fopen` ANSI paths works mostly as well (or bad) as before except when there are actual on-disk name collisions. However, the other way around, using the new encoding with older libass binaries, will in general fail unless the paths happen to be pure 7bit US-ASCII. If you want to make use of arbitrary paths but also wish to continue to support older libass versions, you should continue to always use the `fopen` encoding if `ass_library_version() < 0x01502002`. Technically, this should be accompanied by an increase in the minor soname version, but there is none because the change is Win32-specific and the minor soname version is not even used by the dynamic linker in common MS Windows setups. Signed-off-by: Oleg Oshmyan <chortos@inbox.lv>
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index 465ecd0..50a779f 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -4,7 +4,7 @@ AM_CFLAGS = -std=gnu99 -Wall -Wextra -Wno-sign-compare -Wno-unused-parameter \
-D_GNU_SOURCE
LIBASS_LT_CURRENT = 10
-LIBASS_LT_REVISION = 3
+LIBASS_LT_REVISION = 4
LIBASS_LT_AGE = 1
nasm_verbose = $(nasm_verbose_$(V))