summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2012-10-01 17:37:00 +0200
committerGrigori Goronzy <greg@blackbox>2012-10-01 17:37:00 +0200
commit840ce4c2d9381e340c3239d104933fea85fff3e5 (patch)
treec113cc481f569a9e6e253db40b94cc7775761c55 /configure.ac
parent146d60f698e9a5ef79e68a27e768d2f4dd40068d (diff)
downloadlibass-840ce4c2d9381e340c3239d104933fea85fff3e5.tar.bz2
libass-840ce4c2d9381e340c3239d104933fea85fff3e5.tar.xz
shaper: add UCDN support
Add explicit support for UCDN, without relying on any HarfBuzz integration. This finally allows easy usage of HarfBuzz without glib, ICU, or some other big bloated library!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9f9071..0d24c35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,10 @@ PKG_CHECK_MODULES([HARFBUZZ], harfbuzz >= 0.7.0, [
], [harfbuzz=false])
fi
+if test x$harfbuzz = xtrue; then
+ AC_SEARCH_LIBS([ucdn_get_unicode_version], [ucdn], AC_DEFINE(CONFIG_UCDN, 1, [use ucdn]))
+fi
+
if test x$enable_enca != xno; then
PKG_CHECK_MODULES([ENCA], enca, [
CFLAGS="$CFLAGS $ENCA_CFLAGS"