summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2009-07-13 22:21:51 +0200
committerGrigori Goronzy <greg@blackbox>2009-07-13 22:21:51 +0200
commit94d41042a9006375eecf5332e9a59657a0c8a492 (patch)
treefd3e8b09df67f4db21305f4f0ec9a31faebf804e /Makefile.am
parent81070577a7bf81231ca79ce4efebc7235a9b605f (diff)
downloadlibass-94d41042a9006375eecf5332e9a59657a0c8a492.tar.bz2
libass-94d41042a9006375eecf5332e9a59657a0c8a492.tar.xz
Rework build system
* Remove checks for functions or headers that are part of ANSI C or C89. * Make enca optional. * Conditionally compile the test program depending on libpng availability.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 08b3844..dd39648 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,4 +5,9 @@ EXTRA_DIST = libass.pc.in Changelog
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libass.pc
-SUBDIRS = libass test
+if HAVE_LIBPNG
+ test = test
+endif
+
+SUBDIRS = libass $(test)
+