summaryrefslogtreecommitdiffstats
path: root/player/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'player/meson.build')
-rw-r--r--player/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/player/meson.build b/player/meson.build
new file mode 100644
index 0000000000..be1e812d3e
--- /dev/null
+++ b/player/meson.build
@@ -0,0 +1,11 @@
+subdir('javascript')
+subdir('lua')
+
+# Older versions of meson don't allow multiple build targets with the same name in the same
+# file. Generate it here for compatibility reasons for windows.
+if win32 and get_option('cplayer') and meson.version().version_compare('< 1.3.0')
+ wrapper_sources= '../osdep/win32-console-wrapper.c'
+ executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
+ name_suffix: 'com', install: true)
+ warning('mpv.com executable will be generated in the player subdirectory.')
+endif