summaryrefslogtreecommitdiffstats
path: root/osdep/mac/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'osdep/mac/meson.build')
-rw-r--r--osdep/mac/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/osdep/mac/meson.build b/osdep/mac/meson.build
index fca38e5282..faebf7e1d6 100644
--- a/osdep/mac/meson.build
+++ b/osdep/mac/meson.build
@@ -19,6 +19,10 @@ if get_option('optimization') != '0'
swift_flags += '-O'
endif
+if macos_touchbar.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_TOUCHBAR']
+endif
+
extra_flags = get_option('swift-flags').split()
swift_flags += extra_flags