summaryrefslogtreecommitdiffstats
path: root/osdep/mac/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'osdep/mac/meson.build')
-rw-r--r--osdep/mac/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/osdep/mac/meson.build b/osdep/mac/meson.build
index faebf7e1d6..de32eb2a3c 100644
--- a/osdep/mac/meson.build
+++ b/osdep/mac/meson.build
@@ -19,10 +19,18 @@ if get_option('optimization') != '0'
swift_flags += '-O'
endif
+if macos_cocoa_cb.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_COCOA_CB']
+endif
+
if macos_touchbar.allowed()
swift_flags += ['-D', 'HAVE_MACOS_TOUCHBAR']
endif
+if macos_media_player.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_MEDIA_PLAYER']
+endif
+
extra_flags = get_option('swift-flags').split()
swift_flags += extra_flags