summaryrefslogtreecommitdiffstats
path: root/osdep/mac/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'osdep/mac/meson.build')
-rw-r--r--osdep/mac/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/osdep/mac/meson.build b/osdep/mac/meson.build
index 8ddbdbaddf..4358173c17 100644
--- a/osdep/mac/meson.build
+++ b/osdep/mac/meson.build
@@ -19,6 +19,14 @@ if get_option('optimization') != '0'
swift_flags += '-O'
endif
+if macos_11_features.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_11_FEATURES']
+endif
+
+if macos_12_features.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_12_FEATURES']
+endif
+
if macos_cocoa_cb.allowed()
swift_flags += ['-D', 'HAVE_MACOS_COCOA_CB']
endif