summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 850b9b5088..ec5d5555c4 100644
--- a/meson.build
+++ b/meson.build
@@ -1226,12 +1226,11 @@ if plain_gl.allowed()
features += {'gl': true}
endif
-features += {'egl-helpers': features['egl'] or egl_android.found() or egl_angle_win32.allowed()}
-if features['egl-helpers']
+if features['egl'] or features['egl-android'] or features['egl-angle-win32']
sources += files('video/out/opengl/egl_helpers.c')
endif
-if features['egl'] and features['egl-helpers']
+if features['gl'] and features['egl']
sources += files('video/filter/vf_gpu.c')
endif