summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorsfan5 <sfan5@live.de>2024-03-21 10:08:48 +0100
committersfan5 <sfan5@live.de>2024-03-21 18:27:08 +0100
commita392f9117027413ed470710d7cd2ff80c5b971fa (patch)
tree51cdb8430a1ef45e3a33820b1c657a2467d44cde /meson.build
parent3679d18b54b21854685ef72eaae7717e44089dc8 (diff)
downloadmpv-a392f9117027413ed470710d7cd2ff80c5b971fa.tar.bz2
mpv-a392f9117027413ed470710d7cd2ff80c5b971fa.tar.xz
meson: get rid of 'egl-helpers' feature
This was just redundant because it's always present together with 'egl'.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 850b9b5088..ec5d5555c4 100644
--- a/meson.build
+++ b/meson.build
@@ -1226,12 +1226,11 @@ if plain_gl.allowed()
features += {'gl': true}
endif
-features += {'egl-helpers': features['egl'] or egl_android.found() or egl_angle_win32.allowed()}
-if features['egl-helpers']
+if features['egl'] or features['egl-android'] or features['egl-angle-win32']
sources += files('video/out/opengl/egl_helpers.c')
endif
-if features['egl'] and features['egl-helpers']
+if features['gl'] and features['egl']
sources += files('video/filter/vf_gpu.c')
endif