summaryrefslogtreecommitdiffstats
path: root/input/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'input/meson.build')
-rw-r--r--input/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/input/meson.build b/input/meson.build
new file mode 100644
index 0000000000..12fe732b43
--- /dev/null
+++ b/input/meson.build
@@ -0,0 +1,20 @@
+icons = ['16', '32', '64', '128']
+foreach size: icons
+ name = 'mpv-icon-8bit-'+size+'x'+size+'.png'
+ icon = custom_target(name,
+ input: join_paths(source_root, 'etc', name),
+ output: name + '.inc',
+ command: [file2string, '@INPUT@', '@OUTPUT@'],
+ )
+ sources += icon
+endforeach
+
+etc_files = ['input.conf', 'builtin.conf']
+foreach file: etc_files
+ etc_file = custom_target(file,
+ input: join_paths(source_root, 'etc', file),
+ output: file + '.inc',
+ command: [file2string, '@INPUT@', '@OUTPUT@'],
+ )
+ sources += etc_file
+endforeach