summaryrefslogtreecommitdiffstats
path: root/etc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'etc/meson.build')
-rw-r--r--etc/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/etc/meson.build b/etc/meson.build
index 12fe732b43..ac9eec0e6f 100644
--- a/etc/meson.build
+++ b/etc/meson.build
@@ -2,9 +2,9 @@ icons = ['16', '32', '64', '128']
foreach size: icons
name = 'mpv-icon-8bit-'+size+'x'+size+'.png'
icon = custom_target(name,
- input: join_paths(source_root, 'etc', name),
+ input: name,
output: name + '.inc',
- command: [file2string, '@INPUT@', '@OUTPUT@'],
+ command: [file2string, '@INPUT@', '@OUTPUT@', '@SOURCE_ROOT@'],
)
sources += icon
endforeach
@@ -12,9 +12,9 @@ endforeach
etc_files = ['input.conf', 'builtin.conf']
foreach file: etc_files
etc_file = custom_target(file,
- input: join_paths(source_root, 'etc', file),
+ input: file,
output: file + '.inc',
- command: [file2string, '@INPUT@', '@OUTPUT@'],
+ command: [file2string, '@INPUT@', '@OUTPUT@', '@SOURCE_ROOT@'],
)
sources += etc_file
endforeach