summaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/common/meson.build b/common/meson.build
new file mode 100644
index 0000000000..202880f365
--- /dev/null
+++ b/common/meson.build
@@ -0,0 +1,11 @@
+version_h = vcs_tag(
+ command: ['git',
+ '--git-dir=' + join_paths(source_root, '.git'),
+ '--work-tree=' + source_root,
+ 'describe', '--always', '--tags', '--dirty'],
+ input: 'version.h.in',
+ output: 'version.h',
+ replace_string: '@VERSION@',
+)
+
+sources += version_h