summaryrefslogtreecommitdiffstats
path: root/TOOLS/osxbundle/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'TOOLS/osxbundle/meson.build')
-rw-r--r--TOOLS/osxbundle/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/TOOLS/osxbundle/meson.build b/TOOLS/osxbundle/meson.build
new file mode 100644
index 0000000000..a271b4120f
--- /dev/null
+++ b/TOOLS/osxbundle/meson.build
@@ -0,0 +1,8 @@
+input = join_paths(source_root, 'TOOLS', 'osxbundle',
+ 'mpv.app', 'Contents', 'Resources', 'icon.icns')
+osxbundle = custom_target('osxbundle',
+ input: input,
+ output: 'icon.icns.inc',
+ command: [file2string, '@INPUT@', '@OUTPUT@'],
+)
+sources += osxbundle