summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authornanahi <130121847+na-na-hi@users.noreply.github.com>2023-10-26 15:13:12 -0400
committerKacper Michajłow <kasper93@gmail.com>2024-03-19 20:23:25 +0100
commitaff376e066359afbb78fca1c53355104281d9712 (patch)
treec95950a0a4dcb325c424c95c0712fdfb64a4297d /test/meson.build
parentbfd016d1013ad6cac9a190ec109e814744055d8c (diff)
downloadmpv-aff376e066359afbb78fca1c53355104281d9712.tar.bz2
mpv-aff376e066359afbb78fca1c53355104281d9712.tar.xz
win32: increase hires timer resolution
timeBeginPeriod() only allows setting minimum timer resolution to 1 ms. However, modern x86 platforms support a minimum timer resolution of 0.5 ms. Use NtSetTimerResolution() instead for the increased resolution, which can be set with MPV_HRT_RES. Additionally, change the units of mp_start_hires_timers(), mp_end_hires_timer(), MPV_HRT_RES, and MPV_HRT_MAX to nanoseconds, in accordance with other functions used in timer.h.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index b45f672c7a..7be1db4777 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -52,6 +52,7 @@ endif
if features['win32-desktop']
test_utils_deps += cc.find_library('imm32')
+ test_utils_deps += cc.find_library('ntdll')
test_utils_deps += cc.find_library('winmm')
endif
test_utils_objects = libmpv.extract_objects(test_utils_files)