summaryrefslogtreecommitdiffstats
path: root/osdep/mac/meson.build
diff options
context:
space:
mode:
authorder richter <der.richter@gmx.de>2024-04-28 19:21:01 +0200
committerder richter <der.richter@gmx.de>2024-05-05 19:02:50 +0200
commit8a61929eb8e62097cf8ef0764dba233000fd1e5f (patch)
tree6d32a34e7ce5d2cb0c4b02b830823e2d3c093d44 /osdep/mac/meson.build
parentcb75ecf19f28cfa00ecd348da13bca2550e85963 (diff)
downloadmpv-8a61929eb8e62097cf8ef0764dba233000fd1e5f.tar.bz2
mpv-8a61929eb8e62097cf8ef0764dba233000fd1e5f.tar.xz
cocoa-cb: add support for macOS color space transformation (EDR/HDR)
by default utilises the color space of the screen on which the window is located. if a specific value is defined, it will instead be utilised. depending on the chosen color space the macOS EDR (HDR) support is activated and that OS's transformation (tone mapping) is used. Fixes #7341
Diffstat (limited to 'osdep/mac/meson.build')
-rw-r--r--osdep/mac/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/osdep/mac/meson.build b/osdep/mac/meson.build
index 8ddbdbaddf..4358173c17 100644
--- a/osdep/mac/meson.build
+++ b/osdep/mac/meson.build
@@ -19,6 +19,14 @@ if get_option('optimization') != '0'
swift_flags += '-O'
endif
+if macos_11_features.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_11_FEATURES']
+endif
+
+if macos_12_features.allowed()
+ swift_flags += ['-D', 'HAVE_MACOS_12_FEATURES']
+endif
+
if macos_cocoa_cb.allowed()
swift_flags += ['-D', 'HAVE_MACOS_COCOA_CB']
endif