summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorder richter <der.richter@gmx.de>2023-11-10 14:34:29 +0100
committerder richter <der.richter@gmx.de>2023-11-10 14:54:37 +0100
commitfc4db187d0ac538cb5cd9fcd7120f4ee25df4690 (patch)
tree8de56871992d2d757d23874d888caf74345af438 /meson.build
parenta54cc02341fed3e1e2408a692aa4753718ee969f (diff)
downloadmpv-fc4db187d0ac538cb5cd9fcd7120f4ee25df4690.tar.bz2
mpv-fc4db187d0ac538cb5cd9fcd7120f4ee25df4690.tar.xz
cocoa: remove OpenGL cocoa backend
the OpenGL cocoa backend was deprecated in 0.29, it has lot of bugs, is completely unmaintained and can't properly playback anything anymore on the newest macOS. it is time to remove it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 3 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index bbd6b78b28..3b2dc2dd79 100644
--- a/meson.build
+++ b/meson.build
@@ -388,11 +388,7 @@ if features['cocoa']
'osdep/macosx_events.m',
'osdep/macosx_menubar.m',
'osdep/main-fn-cocoa.c',
- 'osdep/path-macosx.m',
- 'video/out/cocoa_common.m',
- 'video/out/cocoa/events_view.m',
- 'video/out/cocoa/video_view.m',
- 'video/out/cocoa/window.m')
+ 'osdep/path-macosx.m')
endif
if posix
@@ -1079,7 +1075,6 @@ features += {'gl-cocoa': gl_cocoa.allowed()}
if features['gl-cocoa']
dependencies += GL
features += {'gl': true}
- sources += files('video/out/opengl/context_cocoa.c')
endif
gl_win32 = get_option('gl-win32').require(
@@ -1517,8 +1512,8 @@ if features['cocoa'] and features['swift']
endif
macos_cocoa_cb = get_option('macos-cocoa-cb').require(
- features['cocoa'] and features['swift'],
- error_message: 'Either cocoa or swift could not be found!',
+ features['cocoa'] and features['gl-cocoa'] and features['swift'],
+ error_message: 'Either cocoa, gl-cocoa or swift could not be found!',
)
features += {'macos-cocoa-cb': macos_cocoa_cb.allowed()}
if features['macos-cocoa-cb']