summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKacper Michajłow <kasper93@gmail.com>2023-10-28 21:18:18 +0200
committerDudemanguy <random342@airmail.cc>2023-11-08 04:32:10 +0000
commitfa0929bf712af33ade96e54db4a101664fe466d9 (patch)
treeb15349fa1fc586a5287b4e92313f4920f8d70060 /meson.build
parent0a6c179026654d8c672ce782feaa86a767cbbfe6 (diff)
downloadmpv-fa0929bf712af33ade96e54db4a101664fe466d9.tar.bz2
mpv-fa0929bf712af33ade96e54db4a101664fe466d9.tar.xz
osdep/threads-posix: use CLOCK_MONOTONIC if supported
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 29960196b3..3250ad4e67 100644
--- a/meson.build
+++ b/meson.build
@@ -359,6 +359,10 @@ features += {'win32-threads': win32_threads.allowed()}
if not features['win32-threads']
pthreads = dependency('threads')
sources += files('osdep/threads-posix.c')
+ features += {'pthread-condattr-setclock':
+ cc.has_header_symbol('pthread.h',
+ 'pthread_condattr_setclock',
+ dependencies: pthreads)}
dependencies += pthreads
endif