summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorsfan5 <sfan5@live.de>2023-08-20 22:40:58 +0200
committerDudemanguy <random342@airmail.cc>2023-08-20 21:13:37 +0000
commitecbaf347010530cb7ca1858486e001f804811921 (patch)
treec61ff9610d5304bee0e8cd2e5a586b31d8916a87 /meson.build
parent88d0383a26ebb2d478dd03f58bfc093a0f11d4fa (diff)
downloadmpv-ecbaf347010530cb7ca1858486e001f804811921.tar.bz2
mpv-ecbaf347010530cb7ca1858486e001f804811921.tar.xz
meson: rename all features with underscores
The convention is to use dashes.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 9 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 39e04f0de8..ce1fce2b09 100644
--- a/meson.build
+++ b/meson.build
@@ -962,9 +962,9 @@ if features['sixel']
sources += files('video/out/vo_sixel.c')
endif
-features += {'posix_shm': false}
+features += {'posix-shm': false}
if features['posix']
- features += {'posix_shm': cc.has_function('shm_open', prefix: '#include <sys/mman.h>')}
+ features += {'posix-shm': cc.has_function('shm_open', prefix: '#include <sys/mman.h>')}
endif
spirv_cross = dependency('spirv-cross-c-shared', required: get_option('spirv-cross'))
@@ -1006,18 +1006,18 @@ if features['wayland']
subdir(join_paths('video', 'out'))
endif
-features += {'memfd_create': false}
+features += {'memfd-create': false}
if features['wayland']
- features += {'memfd_create': cc.has_function('memfd_create',
+ features += {'memfd-create': cc.has_function('memfd_create',
prefix: '#define _GNU_SOURCE\n#include <sys/mman.h>')}
endif
-if features['wayland'] and features['memfd_create']
+if features['wayland'] and features['memfd-create']
sources += files('video/out/vo_wlshm.c')
endif
dmabuf_wayland = get_option('dmabuf-wayland').require(
- features['drm'] and features['memfd_create'] and features['wayland'],
- error_message: 'drm, memfd_create, or wayland was not found!',
+ features['drm'] and features['memfd-create'] and features['wayland'],
+ error_message: 'drm, memfd-create or wayland was not found!',
)
features += {'dmabuf-wayland': dmabuf_wayland.allowed()}
if features['dmabuf-wayland']
@@ -1282,10 +1282,9 @@ if features['vulkan'] and features['x11']
sources += files('video/out/vulkan/context_xlib.c')
endif
-features += {'vk_khr_display': cc.has_function('vkCreateDisplayPlaneSurfaceKHR', prefix: '#include <vulkan/vulkan_core.h>',
+features += {'vk-khr-display': cc.has_function('vkCreateDisplayPlaneSurfaceKHR', prefix: '#include <vulkan/vulkan_core.h>',
dependencies: [vulkan])}
-
-if features['vk_khr_display']
+if features['vk-khr-display']
sources += files('video/out/vulkan/context_display.c')
endif