summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Weißschuh <thomas@t-8ch.de>2023-01-19 15:53:00 +0000
committerDudemanguy <random342@airmail.cc>2023-01-19 22:15:14 +0000
commite09bab90ceb29f60e013cb50ecfdb3aa866c24ac (patch)
tree505a35521fe02c2b57ab92cd9768b2aaac3ac47c /meson.build
parentede8d29408f7cb70b37a60daa03802b8e42c6fb7 (diff)
downloadmpv-e09bab90ceb29f60e013cb50ecfdb3aa866c24ac.tar.bz2
mpv-e09bab90ceb29f60e013cb50ecfdb3aa866c24ac.tar.xz
meson: limit vaapi checks
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c117f5ead6..28a007ee05 100644
--- a/meson.build
+++ b/meson.build
@@ -1367,19 +1367,19 @@ if features['vaapi']
'video/vaapi.c')
endif
-vaapi_drm = dependency('libva-drm', version: '>= 1.1.0', required: get_option('vaapi-drm'))
+vaapi_drm = dependency('libva-drm', version: '>= 1.1.0', required: get_option('vaapi-drm').require(features['vaapi']))
features += {'vaapi-drm': features['vaapi'] and egl_drm.allowed() and vaapi_drm.found()}
if features['vaapi-drm']
dependencies += vaapi_drm
endif
-vaapi_wayland = dependency('libva-wayland', version: '>= 1.1.0', required: get_option('vaapi-wayland'))
+vaapi_wayland = dependency('libva-wayland', version: '>= 1.1.0', required: get_option('vaapi-wayland').require(features['vaapi']))
features += {'vaapi-wayland': features['vaapi'] and features['gl-wayland'] and vaapi_wayland.found()}
if features['vaapi-wayland']
dependencies += vaapi_wayland
endif
-vaapi_x11 = dependency('libva-x11', version: '>= 1.1.0', required: get_option('vaapi-x11'))
+vaapi_x11 = dependency('libva-x11', version: '>= 1.1.0', required: get_option('vaapi-x11').require(features['vaapi']))
features += {'vaapi-x11': features['vaapi'] and features['x11'] and vaapi_x11.found()}
if features['vaapi-x11']
dependencies += vaapi_x11