summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKacper Michajłow <kasper93@gmail.com>2023-07-30 12:34:55 +0200
committerDudemanguy <random342@airmail.cc>2023-08-02 18:51:13 +0000
commitdf7a094765b58e74a8c1b678d5a8e2374d906866 (patch)
treeb67eb4de247b4274f120fc81ce440743c8fb694a /meson.build
parent30bf811a8f230e2a84494eaebc82e51b125cbff5 (diff)
downloadmpv-df7a094765b58e74a8c1b678d5a8e2374d906866.tar.bz2
mpv-df7a094765b58e74a8c1b678d5a8e2374d906866.tar.xz
build: remove version.py
After second thought version.py does not do anything useful. Meson has built-in function vcs_tag that mostly replicate what version.py did. For the build time we can just use __DATE__ and __TIME__. Of course this changes time string format a little, but in my opinion it looks nicer in fact. Also it will use local time, instead UTC. But I would argue that date string is only informative for users to check how old the specific mpv build is. It doesn't have to be precise, it weren't for years anyway before recent change.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 2 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index be26cbd633..c49ee8f739 100644
--- a/meson.build
+++ b/meson.build
@@ -556,7 +556,6 @@ tools_directory = join_paths(source_root, 'TOOLS')
docutils_wrapper = find_program(join_paths(tools_directory, 'docutils-wrapper.py'))
file2string = find_program(join_paths(tools_directory, 'file2string.py'))
matroska = find_program(join_paths(tools_directory, 'matroska.py'))
-version_py = find_program(join_paths(source_root, 'version.py'))
ebml_defs = custom_target('ebml_defs.inc',
output: 'ebml_defs.inc',
@@ -568,13 +567,9 @@ ebml_types = custom_target('ebml_types.h',
command: [matroska, '--generate-header', '@OUTPUT@'],
)
-version_h = custom_target('version.h',
- output: 'version.h',
- command: [version_py, '@OUTPUT@'],
- build_always_stale: true,
-)
-sources += [ebml_defs, ebml_types, version_h]
+sources += [ebml_defs, ebml_types]
+subdir('common')
subdir('etc')
subdir('player')
subdir('sub')