summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorcloud11665 <cloud11665@gmail.com>2023-03-25 00:30:57 +0100
committerDudemanguy <random342@airmail.cc>2023-07-01 02:05:23 +0000
commitde7f4fb1ee0d7344d6ca91e5c9f52773e5aac778 (patch)
treeb1a51d43d1b50736164765a4c51bd2ef5ff7e14a /meson.build
parent0bfafd2451b25d25d3a8249373dc63b5d5e94379 (diff)
downloadmpv-de7f4fb1ee0d7344d6ca91e5c9f52773e5aac778.tar.bz2
mpv-de7f4fb1ee0d7344d6ca91e5c9f52773e5aac778.tar.xz
video/image_writer: add avif screenshot support
Notes: - converts the (image) write() api to filenames, because using avio with FILE* is a pain. - adds more debug logs for screenshots. build: rename av1 dependency to avif_muxer wscript: unify lavf dependency with meson
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 78269d1be3..bb3cf61596 100644
--- a/meson.build
+++ b/meson.build
@@ -43,6 +43,7 @@ features = {
'ffmpeg': true,
'gpl': get_option('gpl'),
'jpegxl': libavformat.version().version_compare('>= 59.27.100'),
+ 'avif_muxer': libavformat.version().version_compare('>= 59.24.100'),
'libass': true,
'threads': true,
}