summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-07-25 14:38:25 -0500
committerDudemanguy <random342@airmail.cc>2023-07-25 20:04:54 +0000
commitde112a7932edd4e3a16253a01fc3ec90f7ca6fc4 (patch)
tree7e18a4fe3a411682718e5041390c81a62c61fcf2 /meson.build
parent4332553db50a46f6e0ca95466fe54aca0d175307 (diff)
downloadmpv-de112a7932edd4e3a16253a01fc3ec90f7ca6fc4.tar.bz2
mpv-de112a7932edd4e3a16253a01fc3ec90f7ca6fc4.tar.xz
build: remove unneeded libdl requirement for vaapi
Curiously, vaapi requiring libdl has always existed ever since support was added to mpv (2827295703c74e3c119df9a435aa856e268c2ea9). After some investigation in IRC from uau and JEEB, it was concluded that the libdl requirement was blindly copied from the vdpau check above it. At the time, the vdpau code actually used dlsym so it was needed. The check was later dropped when waf support was added (7e2edad8efea55e8df1faa695d1389ef4e326d7c). However, the requirement in vaapi lived on, and actually it was never needed. libva does use dl when building its libraries unsurprisingly, but this isn't relevant to mpv in any way. Just drop it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9cf3941d3f..5a82220b38 100644
--- a/meson.build
+++ b/meson.build
@@ -1418,8 +1418,8 @@ if features['vaapi-x11']
sources += files('video/out/vo_vaapi.c')
endif
-vaapi = get_option('vaapi').require(libva.found() and features['libdl'] and
- (features['vaapi-drm'] or features['vaapi-wayland'] or features['vaapi-x11']))
+vaapi = get_option('vaapi').require(libva.found() and (features['vaapi-drm'] or
+ features['vaapi-wayland'] or features['vaapi-x11']))
features += {'vaapi': vaapi.allowed()}
if features['vaapi']