summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorShreesh Adiga <16567adigashreesh@gmail.com>2022-04-16 22:04:13 +0530
committerKacper Michajłow <kasper93@gmail.com>2024-04-27 01:08:22 +0200
commitd9c5aef98d1607594a15a905f5af06c737c34c27 (patch)
tree47773f9265c0edbc33bc768c2f190c1903f8df39 /meson.build
parent773c5e2ae0337013732321c871c287aef8436c32 (diff)
downloadmpv-d9c5aef98d1607594a15a905f5af06c737c34c27.tar.bz2
mpv-d9c5aef98d1607594a15a905f5af06c737c34c27.tar.xz
vf_gpu: vulkan and egl implementations
Abstract out EGL, and allow choosing between EGL and vulkan at runtime. vf_gpu_egl.c contains GL specific context and creation/destroy code, vf_gpu_vulkan.c contains Vulkan specific. This allows vf_gpu being built in systems where EGL is not available and where Vulkan is available.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 117ebeb7b8..be43e8e1c8 100644
--- a/meson.build
+++ b/meson.build
@@ -1249,7 +1249,7 @@ if features['egl'] or features['egl-android'] or features['egl-angle-win32']
endif
if features['gl'] and features['egl']
- sources += files('video/filter/vf_gpu.c')
+ sources += files('video/filter/vf_gpu_egl.c')
endif
if features['gl']
@@ -1274,7 +1274,8 @@ features += {'vulkan': vulkan.found()}
if features['vulkan']
dependencies += vulkan
sources += files('video/out/vulkan/context.c',
- 'video/out/vulkan/utils.c')
+ 'video/out/vulkan/utils.c',
+ 'video/filter/vf_gpu_vulkan.c')
endif
if features['vulkan'] and features['android']
@@ -1299,6 +1300,10 @@ if features['vk-khr-display']
sources += files('video/out/vulkan/context_display.c')
endif
+if features['vulkan'] or (features['gl'] and features['egl'])
+ sources += files('video/filter/vf_gpu.c')
+endif
+
# hwaccel
ffnvcodec = dependency('ffnvcodec', version: '>= 11.1.5.1', required: false)