summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@overt.org>2023-08-19 21:13:02 -0700
committerPhilip Langdale <philipl@overt.org>2023-08-19 21:16:20 -0700
commitd2074fee0a489aba747cd71ee15d5f996230c968 (patch)
treeb3ce469a74063db2007699f00676c2baf62ab638 /meson.build
parentf7151932df4b239a8ee724117103cc15635987c5 (diff)
downloadmpv-d2074fee0a489aba747cd71ee15d5f996230c968.tar.bz2
mpv-d2074fee0a489aba747cd71ee15d5f996230c968.tar.xz
meson: remove redundant libplacebo version check for Vulkan interop
With the bump of the required base libplacebo version, we no longer need to do an additional check for Vulkan interop - it will always be new enough.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d7dec116f1..39e04f0de8 100644
--- a/meson.build
+++ b/meson.build
@@ -1330,9 +1330,9 @@ endif
vulkan_interop = get_option('vulkan-interop').require(
features['vulkan'] and vulkan.version().version_compare('>=1.3.238') and
- features['libplacebo'] and libplacebo.version().version_compare('>=6.278.0') and
+ features['libplacebo'] and
libavutil.version().version_compare('>=58.11.100'),
- error_message: 'Vulkan Interop requires vulkan headers >= 1.3.238, libplacebo >= 6.278.0, and libavutil >= 58.11.100',
+ error_message: 'Vulkan Interop requires vulkan headers >= 1.3.238, libplacebo, and libavutil >= 58.11.100',
)
features += {'vulkan-interop': vulkan_interop.allowed()}
if vulkan_interop.allowed()