summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorrcombs <rcombs@rcombs.me>2022-07-13 21:26:14 -0500
committerrcombs <rcombs@rcombs.me>2023-11-16 09:48:20 -0800
commitca45b71edc9148ab6074947fa8ca0cd1eb4d5572 (patch)
treecb9340e07515d15122c7fdc195b2e7c736bf93c2 /meson.build
parent62b1ce0a55b165c1bad2f5ca4ec136f929b792db (diff)
downloadmpv-ca45b71edc9148ab6074947fa8ca0cd1eb4d5572.tar.bz2
mpv-ca45b71edc9148ab6074947fa8ca0cd1eb4d5572.tar.xz
hwdec: support videotoolbox with libplacebo
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 15 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3b2dc2dd79..fdfc526525 100644
--- a/meson.build
+++ b/meson.build
@@ -1362,7 +1362,7 @@ endif
ios_gl = cc.has_header_symbol('OpenGLES/ES3/glext.h', 'GL_RGB32F', required: get_option('ios-gl'))
features += {'ios-gl': ios_gl}
if features['ios-gl']
- sources += files('video/out/opengl/hwdec_ios.m')
+ sources += files('video/out/hwdec/hwdec_ios_gl.m')
endif
rpi_mmal_opt = get_option('rpi-mmal').require(
@@ -1443,8 +1443,21 @@ videotoolbox_gl = get_option('videotoolbox-gl').require(
error_message: 'gl-cocoa nor ios-gl could be found!',
)
features += {'videotoolbox-gl': videotoolbox_gl.allowed()}
+corevideo = dependency('appleframeworks', modules: ['CoreVideo'], required: get_option('videotoolbox-pl'))
+videotoolbox_pl = get_option('videotoolbox-pl').require(
+ features['vulkan'] and corevideo.found(),
+ error_message: 'vulkan or CV metal support could be found!',
+)
+features += {'videotoolbox-pl': videotoolbox_pl.allowed()}
+if features['videotoolbox-gl'] or features['videotoolbox-pl']
+ sources += files('video/out/hwdec/hwdec_vt.c')
+endif
if features['videotoolbox-gl']
- sources += files('video/out/opengl/hwdec_osx.c')
+ sources += files('video/out/hwdec/hwdec_mac_gl.c')
+endif
+if features['videotoolbox-pl']
+ dependencies += corevideo
+ sources += files('video/out/hwdec/hwdec_vt_pl.m')
endif