summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorder richter <der.richter@gmx.de>2024-03-17 17:12:09 +0100
committerder richter <der.richter@gmx.de>2024-03-18 20:29:27 +0100
commitc8088d801a99109b213a416da20a9e5d712ca492 (patch)
tree1d496223f90115d1556379bf954d1b12e3f16fed /meson.build
parentc155c18023ee9278c279c2a20fd8bccda9d3aa16 (diff)
downloadmpv-c8088d801a99109b213a416da20a9e5d712ca492.tar.bz2
mpv-c8088d801a99109b213a416da20a9e5d712ca492.tar.xz
mac/touchbar: rewrite touch bar in swift
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 159d1feebc..40c5551fe0 100644
--- a/meson.build
+++ b/meson.build
@@ -1556,7 +1556,7 @@ macos_touchbar = get_option('macos-touchbar').require(
)
features += {'macos-touchbar': macos_touchbar.allowed()}
if features['macos-touchbar']
- sources += files('osdep/mac/touchbar.m')
+ swift_sources += files('osdep/mac/touch_bar.swift')
endif
if features['swift'] and swift_sources.length() > 0