summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2022-11-07 18:02:22 -0600
committerDudemanguy <random342@airmail.cc>2023-05-09 20:37:17 +0000
commitbaa9d56481fe0f7633c77d0e7ee6ffd33b3a3783 (patch)
tree083f4629e6c51342edcccf7523e8d645b259fab3 /meson.build
parenta1580b6424df95741452d3eff87d24a76305a0a8 (diff)
downloadmpv-baa9d56481fe0f7633c77d0e7ee6ffd33b3a3783.tar.bz2
mpv-baa9d56481fe0f7633c77d0e7ee6ffd33b3a3783.tar.xz
osdep: separate out macos paths from path-unix.c
macOS really has completely different path conventions that mpv doesn't take into account and it treats it just like any other old unix-like system. This means mpv enforces certain conventions on it (like all the XDG stuff) that doesn't really apply. Since we'd like to use more of this but at the same time not distrupt mac users even more, let's just copy and paste the current code to a new file, update the build and call it a day. This way, the paths of these two platforms can more freely diverge.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 30cb219a5b..bc7361af2f 100644
--- a/meson.build
+++ b/meson.build
@@ -293,6 +293,8 @@ endif
darwin = host_machine.system() == 'darwin'
win32 = host_machine.system() == 'cygwin' or host_machine.system() == 'windows'
posix = not win32
+
+features += {'darwin': darwin}
features += {'posix': posix}
features += {'dos-paths': win32, 'win32': win32}
@@ -407,11 +409,14 @@ if posix and not features['cocoa']
endif
if darwin
- sources += files('osdep/timer-darwin.c')
+ path_source = files('osdep/path-darwin.c')
+ sources += path_source + files('osdep/timer-darwin.c')
+
endif
if posix and not darwin
- sources += files('osdep/timer-linux.c')
+ sources += files('osdep/path-unix.c',
+ 'osdep/timer-linux.c')
endif
cd_devices = {