summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-09-17 21:59:16 -0500
committerDudemanguy <random342@airmail.cc>2023-10-10 19:10:55 +0000
commitba4b408b8bdc2aa0059abaaffe8b16f28aec480b (patch)
treeb4bfe0dc0f5d08e2eb1a596ddb64635c793accc3 /meson.build
parenta899e14bccb667af243f8fce454160e17ae45c2a (diff)
downloadmpv-ba4b408b8bdc2aa0059abaaffe8b16f28aec480b.tar.bz2
mpv-ba4b408b8bdc2aa0059abaaffe8b16f28aec480b.tar.xz
osdep: rename polldev to poll_wrapper
Originally, this was added as purely a shim for macOS. However since we want to do high resolution polling which is not neccesarily available on all platforms, making this a generic wrapper for poll functions is useful so rename it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6806105caa..91b8e84b15 100644
--- a/meson.build
+++ b/meson.build
@@ -403,7 +403,7 @@ if posix
subprocess_source = files('osdep/subprocess-posix.c')
sources += path_source + subprocess_source + \
files('input/ipc-unix.c',
- 'osdep/polldev.c',
+ 'osdep/poll_wrapper.c',
'osdep/terminal-unix.c',
'sub/filter_regex.c')
endif