summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@overt.org>2023-02-05 17:28:25 -0800
committerNiklas Haas <github-daiK1o@haasn.dev>2023-03-26 21:00:23 +0200
commitb77f88157e82e644c88c5e095093ef7229f29542 (patch)
tree234f9734fc8bba52ef99806b012c852473f7a931 /meson.build
parent664f197746dcd64beb528ffba422ca84862fe208 (diff)
downloadmpv-b77f88157e82e644c88c5e095093ef7229f29542.tar.bz2
mpv-b77f88157e82e644c88c5e095093ef7229f29542.tar.xz
meson: bump libplacebo-next required version to 5.264
This is the latest stable release, and what we should use for libplacebo-next per haasn's recommendation. The previous 202 version wasn't even a release.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 1597543e0a..4a8fa203cc 100644
--- a/meson.build
+++ b/meson.build
@@ -917,13 +917,13 @@ if features['libplacebo']
sources += files('video/out/placebo/ra_pl.c',
'video/out/placebo/utils.c')
pl_api_ver = libplacebo.version().split('.')[1]
- if pl_api_ver.version_compare('>=202')
+ if pl_api_ver.version_compare('>=264.0')
features += {'libplacebo-next': true}
- message('libplacebo v4.202+ found! Enabling vo_gpu_next.')
+ message('libplacebo v5.264.0+ found! Enabling vo_gpu_next.')
sources += files('video/out/vo_gpu_next.c',
'video/out/gpu_next/context.c')
else
- message('libplacebo v4.202+ not found! Disabling vo_gpu_next.')
+ message('libplacebo v5.264.0+ not found! Disabling vo_gpu_next.')
endif
endif