summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKacper Michajłow <kasper93@gmail.com>2023-11-27 20:19:35 +0100
committerDudemanguy <random342@airmail.cc>2023-11-27 20:43:04 +0000
commitaea8a82478a6f1ec5312139400f011f4a33c54ad (patch)
tree5ec01708cc61437fb3dfdf4fe06aef97c518372a /meson.build
parentfacbbd1110001ca859c2fd47412518a36cc16d16 (diff)
downloadmpv-aea8a82478a6f1ec5312139400f011f4a33c54ad.tar.bz2
mpv-aea8a82478a6f1ec5312139400f011f4a33c54ad.tar.xz
meson: move mpv.com target after mpv.exe to avoid meson version warning
meson is able to detect blocks of code that are guarded with version checks, but we did that in reverse order and mpv.exe was complaining.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index a47aa54ce2..2fe50267df 100644
--- a/meson.build
+++ b/meson.build
@@ -1686,13 +1686,6 @@ features += {'libmpv-' + get_option('default_library'): get_option('libmpv')}
# build targets
if win32
- # Older meson versions generate this in the player subdirectory.
- if get_option('cplayer') and meson.version().version_compare('>= 1.3.0')
- wrapper_sources= 'osdep/win32-console-wrapper.c'
- executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
- name_suffix: 'com', install: true)
- endif
-
windows = import('windows')
res_flags = ['--codepage=65001']
@@ -1768,6 +1761,13 @@ if get_option('cplayer')
mpv = executable('mpv', objects: libmpv.extract_all_objects(recursive: true), dependencies: dependencies,
win_subsystem: 'windows,6.0', install: true)
+
+ # Older meson versions generate this in the player subdirectory.
+ if win32 and meson.version().version_compare('>= 1.3.0')
+ wrapper_sources= 'osdep/win32-console-wrapper.c'
+ executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
+ name_suffix: 'com', install: true)
+ endif
endif
if get_option('tests')