summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-01-31 10:12:44 -0600
committerDudemanguy <random342@airmail.cc>2023-02-02 14:22:09 +0000
commita9c5414b86126af955d1d0bbf8a34d16a2f443b7 (patch)
tree6f623bb4509782fc80c6255d14e525a05a4b669e /meson.build
parentbf3228142521b0bec633b741c0c97042bb20fe93 (diff)
downloadmpv-a9c5414b86126af955d1d0bbf8a34d16a2f443b7.tar.bz2
mpv-a9c5414b86126af955d1d0bbf8a34d16a2f443b7.tar.xz
meson: check macos touchbar with has_header
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6d8a10cdf5..753cd94d94 100644
--- a/meson.build
+++ b/meson.build
@@ -1544,8 +1544,8 @@ if swift.allowed()
endif
macos_touchbar = get_option('macos-touchbar').require(
- features['cocoa'] and cc.compiles(files(join_paths(fragments, 'touchbar.m')), name: 'macos-touchbar check'),
- error_message: 'Either cocoa could not be found or the macos-touchbar check failed!',
+ features['cocoa'] and cc.has_header('AppKit/NSTouchBar.h'),
+ error_message: 'Either cocoa could not be found or AppKit/NSTouchBar.h could not be found!',
)
features += {'macos-touchbar': macos_touchbar.allowed()}
if features['macos-touchbar']