summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-08-12 17:54:11 -0500
committerDudemanguy <random342@airmail.cc>2023-08-20 02:01:39 +0000
commita0038504a3ef408304f87cda32f3aec7cd9975e3 (patch)
treed3e6bfa397297c0d1427d2ccaaadcd22c1b30021 /meson.build
parent19384e07e4a34a2f6eb54da8d683d5536d4b694b (diff)
downloadmpv-a0038504a3ef408304f87cda32f3aec7cd9975e3.tar.bz2
mpv-a0038504a3ef408304f87cda32f3aec7cd9975e3.tar.xz
x11: require randr 1.4
There really is no reason to not just hard require randr 1.4. xorg added 1.4 support in 2012 and someone somehow using an xorg server older than that today surely has several other problems.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7eb6f95cb2..1a92ef9f40 100644
--- a/meson.build
+++ b/meson.build
@@ -1037,7 +1037,7 @@ x11 = {
dependency('xext', version: '>= 1.0.0', required: x11_opt),
dependency('xinerama', version: '>= 1.0.0', required: x11_opt),
dependency('xpresent', version: '>= 1.0.0', required: x11_opt),
- dependency('xrandr', version: '>= 1.2.0', required: x11_opt)],
+ dependency('xrandr', version: '>= 1.4.0', required: x11_opt)],
}
x11_deps = true
foreach dep: x11['deps']