summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-11-28 08:51:47 -0600
committerDudemanguy <random342@airmail.cc>2023-11-28 21:47:13 +0000
commit60a31a8a284e539043c47a33ff90f3d55aade6a8 (patch)
treead56fcc09105430b57811800bb13a1a7c45ecf52 /meson.build
parent8f1f188bd69433d9bf61a38603e2197fc5454b8d (diff)
downloadmpv-60a31a8a284e539043c47a33ff90f3d55aade6a8.tar.bz2
mpv-60a31a8a284e539043c47a33ff90f3d55aade6a8.tar.xz
build: only directly link shaderc and spirv-cross on windows
See 1b035402a688a5d116a9014e8930d7863481eeed. This is only relevant if you are using d3d11 on --vo=gpu which is windows-only. For all other platforms, vulkan uses libplacebo which uses shaderc. mpv itself doesn't need it in those cases.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2fe50267df..6d8ca78c3d 100644
--- a/meson.build
+++ b/meson.build
@@ -939,7 +939,7 @@ if features['sdl2-video']
sources += files('video/out/vo_sdl.c')
endif
-shaderc = dependency('shaderc', required: get_option('shaderc'))
+shaderc = dependency('shaderc', required: get_option('shaderc').require(features['win32-desktop']))
features += {'shaderc': shaderc.found()}
if features['shaderc']
dependencies += shaderc
@@ -958,7 +958,7 @@ if features['posix']
features += {'posix-shm': cc.has_function('shm_open', prefix: '#include <sys/mman.h>')}
endif
-spirv_cross = dependency('spirv-cross-c-shared', required: get_option('spirv-cross'))
+spirv_cross = dependency('spirv-cross-c-shared', required: get_option('spirv-cross').require(features['win32-desktop']))
features += {'spirv-cross': spirv_cross.found()}
if features['spirv-cross']
dependencies += spirv_cross