summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorrcombs <rcombs@rcombs.me>2021-05-26 17:55:08 -0500
committersfan5 <sfan5@live.de>2023-06-25 11:01:58 +0200
commit57dae8f42c0f08a1cf26ea71adb9a3fc5cef4cc1 (patch)
tree9c93f5d946c4e24b1376cd6459f9ea227dfbc79a /meson.build
parent0463096b3c5a717a7c181801c8df797b046989fc (diff)
downloadmpv-57dae8f42c0f08a1cf26ea71adb9a3fc5cef4cc1.tar.bz2
mpv-57dae8f42c0f08a1cf26ea71adb9a3fc5cef4cc1.tar.xz
osdep: add mp_get_user_langs
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2d42843d71..78269d1be3 100644
--- a/meson.build
+++ b/meson.build
@@ -385,6 +385,7 @@ features += {'cocoa': cocoa.found()}
if features['cocoa']
dependencies += cocoa
sources += files('osdep/apple_utils.c',
+ 'osdep/language-apple.c',
'osdep/macosx_application.m',
'osdep/macosx_events.m',
'osdep/macosx_menubar.m',
@@ -407,7 +408,8 @@ if posix
endif
if posix and not features['cocoa']
- sources += files('osdep/main-fn-unix.c')
+ sources += files('osdep/main-fn-unix.c',
+ 'osdep/language-posix.c')
endif
if darwin
@@ -492,6 +494,7 @@ if features['win32-desktop']
subprocess_source = files('osdep/subprocess-win.c')
sources += path_source + subprocess_source + \
files('input/ipc-win.c',
+ 'osdep/language-win.c',
'osdep/main-fn-win.c',
'osdep/terminal-win.c',
'video/out/w32_common.c',