summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Weißschuh <thomas@t-8ch.de>2023-01-19 03:14:23 +0000
committerDudemanguy <random342@airmail.cc>2023-01-19 22:15:14 +0000
commit491aaacca6528c767cd1b5ba7797dea1c09957ae (patch)
tree79686491bfaa2113d773f4a1234a2c82efa09c0e /meson.build
parent2056bf1b4e72c5350182e4b150ec1317431cf921 (diff)
downloadmpv-491aaacca6528c767cd1b5ba7797dea1c09957ae.tar.bz2
mpv-491aaacca6528c767cd1b5ba7797dea1c09957ae.tar.xz
meson: remove dependency from libmpv to plain-gl
The libmpv feature should not have any impact on the built core code. Otherwise a mpv executable compiled in a build together with libmpv has different features than one from a build without. The gl feature doesn't hurt, so always enable it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4b9892e5bc..6dffe2105c 100644
--- a/meson.build
+++ b/meson.build
@@ -1194,8 +1194,8 @@ if features['egl-x11']
endif
plain_gl = get_option('plain-gl').require(
- get_option('libmpv') and gl_allowed,
- error_message: 'libmpv was not enabled!',
+ gl_allowed,
+ error_message: 'gl was not enabled!',
)
features += {'plain-gl': plain_gl.allowed()}
if features['plain-gl']