summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLaserEyess <lasereyess@users.noreply.github.com>2023-07-31 14:35:24 -0400
committersfan5 <sfan5@live.de>2023-07-31 21:40:10 +0200
commit3b198668821685295e1e122df92adfbacc55a8f5 (patch)
tree3cd809049c5b0cd80d3e73d6c4c927fd1e339bea /meson.build
parent7adb56ccd9725fe84d50e35bb929c7d9f3b652fc (diff)
downloadmpv-3b198668821685295e1e122df92adfbacc55a8f5.tar.bz2
mpv-3b198668821685295e1e122df92adfbacc55a8f5.tar.xz
drm: bump minimum version to 2.4.105
Debian 12 is out, with 2.4.114, and Ubuntu 22.04 has 2.4.110, this #ifdef is no longer needed
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 56d8888fc9..be26cbd633 100644
--- a/meson.build
+++ b/meson.build
@@ -909,7 +909,7 @@ if features['direct3d']
sources += files('video/out/vo_direct3d.c')
endif
-drm = dependency('libdrm', version: '>= 2.4.75', required: get_option('drm'))
+drm = dependency('libdrm', version: '>= 2.4.105', required: get_option('drm'))
features += {'drm': drm.found() and (features['vt.h'] or features['consio.h'])}
if features['drm']
dependencies += drm
@@ -922,9 +922,6 @@ if features['drm']
'video/out/vo_drm.c')
endif
-# This can be removed roughly when Debian 12 is released.
-features += {'drm-is-kms': features['drm'] and drm.version().version_compare('>= 2.4.105')}
-
gbm = dependency('gbm', version: '>=17.1.0', required: get_option('gbm'))
features += {'gbm': gbm.found()}
if features['gbm']