summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-02-24 16:24:49 -0600
committerDudemanguy <random342@airmail.cc>2023-03-02 15:45:27 +0000
commit3535e326dcb8b7d46e2fa9c43ec330d348a4bf6e (patch)
tree118d30eff3f0e2437fc6f8a3f2d77adc66a37933 /meson.build
parent3eae9d6c0fdfd49d38a90ab53f23fcd533df0a58 (diff)
downloadmpv-3535e326dcb8b7d46e2fa9c43ec330d348a4bf6e.tar.bz2
mpv-3535e326dcb8b7d46e2fa9c43ec330d348a4bf6e.tar.xz
player: remove unittest option
Since meson has its own unit testing system, let's rework mpv's tests so they integrate nicely with this. To prepare for this, start off by dropping the unittest option. Of course, this means that tests will no longer be supported in the waf build at all but it will be dropped anyway. Note that the tests option is preserved for the meson build. We will still make use of this in the future commits.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 0 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index 0db557f50d..b57ce9d3c0 100644
--- a/meson.build
+++ b/meson.build
@@ -342,19 +342,6 @@ if features['cplugins']
link_flags += '-rdynamic'
endif
-features += {'tests': get_option('tests')}
-if features['tests']
- sources += files('test/chmap.c',
- 'test/gl_video.c',
- 'test/img_format.c',
- 'test/json.c',
- 'test/linked_list.c',
- 'test/paths.c',
- 'test/scale_sws.c',
- 'test/scale_test.c',
- 'test/tests.c')
-endif
-
# Note: this include is only used for windows pthreads and
# must be accompanied immediately by the following flags.
# This currently works because these are the last flags set
@@ -752,10 +739,6 @@ if features['zimg']
dependencies += zimg
sources += files('video/filter/vf_fingerprint.c',
'video/zimg.c')
- if features['tests']
- sources += files('test/repack.c',
- 'test/scale_zimg.c')
- endif
features += {'zimg-st428': zimg.version().version_compare('>= 3.0.5')}
endif