summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2024-02-03 14:27:46 -0600
committerDudemanguy <random342@airmail.cc>2024-02-05 17:41:06 +0000
commit343a5fd345a84572ea5693a805119067d5b0fbc8 (patch)
tree4fbce1c7408194fe9f605d29d194525d30d92927 /meson.build
parent8ecb462a9c2d8003e9972fd20dd2bb713389ed2c (diff)
downloadmpv-343a5fd345a84572ea5693a805119067d5b0fbc8.tar.bz2
mpv-343a5fd345a84572ea5693a805119067d5b0fbc8.tar.xz
player: remove all rpi-specific code
vo_rpi and its related code has pretty much historically been a disaster in mpv. The build regularly gets broken and since nobody uses it, it takes months for anyone to notice. There was also that time where fullscreen was broken for about a year and a half. Also building in waf was entirely broken for about a couple of years or so due to mysterious reasons no one ever figured out (meson magically fixed it). Anyways, once again the build is broken due to rpi being forgotten about again, but instead of pretending to support this crap. Just drop it all. Nowadays, mmal hwdec is a relic since these devices are better off using the v4l2m2m ffmpeg fork instead which actually uses KMS properly. RPI 1 and 2 probably can't do this and will remain broken but oh well blame Broadcom for being special snowflakes and not using standard APIs (my rockpro worked out of the box; just saying). RPI 2 is nearly 10 years old anyways, so I think you can afford a new SBC by now. If we were nicer, there would be a deprecation period, but this is broken in the last major release anyway so too late. Closes #13402.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 1 insertions, 22 deletions
diff --git a/meson.build b/meson.build
index 8a96176d85..8c7730f6b8 100644
--- a/meson.build
+++ b/meson.build
@@ -1219,16 +1219,7 @@ if plain_gl.allowed()
features += {'gl': true}
endif
-rpi = dependency('/opt/vc/lib/pkgconfig/brcmegl.pc', 'brcmegl', required: get_option('rpi'))
-features += {'rpi': gl_allowed and rpi.found()}
-if features['rpi']
- dependencies += rpi
- features += {'gl': true}
- sources += files('video/out/opengl/context_rpi.c')
-endif
-
-features += {'egl-helpers': features['egl'] or egl_android.found() or
- egl_angle_win32.allowed() or features['rpi']}
+features += {'egl-helpers': features['egl'] or egl_android.found() or egl_angle_win32.allowed()}
if features['egl-helpers']
sources += files('video/out/opengl/egl_helpers.c')
endif
@@ -1377,18 +1368,6 @@ if features['ios-gl']
sources += files('video/out/hwdec/hwdec_ios_gl.m')
endif
-rpi_mmal_opt = get_option('rpi-mmal').require(
- features['rpi'],
- error_message: 'rpi was not found!',
-)
-rpi_mmal = dependency('/opt/vc/lib/pkgconfig/mmal.pc', 'mmal', required: rpi_mmal_opt)
-features += {'rpi-mmal': rpi_mmal.found()}
-if features['rpi-mmal']
- dependencies += rpi_mmal
- sources += files('video/out/opengl/hwdec_rpi.c',
- 'video/out/vo_rpi.c')
-endif
-
libva = dependency('libva', version: '>= 1.1.0', required: get_option('vaapi'))
vaapi_drm = dependency('libva-drm', version: '>= 1.1.0',