summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2023-10-18 20:32:16 +0600
committersfan5 <sfan5@live.de>2023-10-20 21:31:09 +0200
commit2fa695c3f9d4164344228ef4083e87369de3bb33 (patch)
tree86479e5d70197a27615a55ee47cdb3d3502d63e7 /meson.build
parent3fb4eb2ba47fea78e69937971974f42cba82d1df (diff)
downloadmpv-2fa695c3f9d4164344228ef4083e87369de3bb33.tar.bz2
mpv-2fa695c3f9d4164344228ef4083e87369de3bb33.tar.xz
osdep: drop atomic fallback
even msvc (which mpv apparently doesn't support) supports C11 atomics now. no need to carry around fallback with subtle semantic differences.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 3 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 6561fa89e5..ba9e0caa0f 100644
--- a/meson.build
+++ b/meson.build
@@ -333,6 +333,9 @@ if features['libdl']
dependencies += libdl
endif
+# C11 atomics are mandatory but linking to the library is not always required.
+dependencies += cc.find_library('atomic', required: false)
+
cplugins = get_option('cplugins').require(
win32 or (features['libdl'] and cc.has_link_argument('-rdynamic')),
error_message: 'cplugins not supported by the os or compiler!',
@@ -731,13 +734,6 @@ if features['sdl2-gamepad']
sources += files('input/sdl_gamepad.c')
endif
-stdatomic_dep = cc.find_library('atomic', required: false)
-features += {'stdatomic': cc.has_header_symbol('stdatomic.h', 'atomic_int', dependencies: stdatomic_dep,
- required: get_option('stdatomic'))}
-if features['stdatomic']
- dependencies += stdatomic_dep
-endif
-
uchardet_opt = get_option('uchardet').require(
features['iconv'],
error_message: 'iconv was not found!',